Something with the Steam Boiler

If you have any problems with your Dream T tank machine where it worked fine out of the box but sometime later something happened during the 2-Year warranty period, ask about it here. Once fixed please keep us posted on what had to be done to resolve the problem.
Post Reply

Something with the Steam Boiler

Post by GooseVR1 »

Thought this was the best place for this post - had the problem not really "resolved itself" I would have certainly made a call for help; thought I'd post here to share the tale.

It's been about 2 weeks behind the Dream T and the experience so far has been fantastic. I've dialed in a coffee or two, and I'm getting the hang of steaming/frothing - the local dairy farm sells a "Royal Rich" - a 3.5% milkfat, and it's great.

I don't remember exactly what I was doing, but I think it was using the hot water dispenser. Anyways, the point is that the steam boiler wanted more water and at that moment the tank decided to be empty. I heard the pump click on to refil the steam boiler as usual, but it went on longer than normal and then suddenly the machine put our 3 or 4 aggressive "puffs" of steam somewhere either from the top of the steam arm or by the steam knob; it was like "steam erupting from under the hood of the beast."

Then the machine powered off and I couldn't get it started again. After a full minute of worry, I realized the GFI had tripped. After resetting that and refilling the tank, I observed the pump turning on to refill the steam boiler (used economy mode to let the brew boiler heat up and then turned it off) but the pump never stopped! Consequently, water steamed out from somewhere behind/under the water tank and dripped all over the counter and onto the floor.

Didn't really know what to do so I turned off the machine and unplugged it. Then I started to take some panels off while trying to search this forum for advice - read a bunch of things from a bad OPV to wondering what a vaccuum breaker does. In any case, 30 minutes later the Dream had cooled down some - so I had powered it back on...and to my surprise things were seemingly normal again. Well - I guess some of the moisture boiling off the boilers made some "different" noises than I was used to hearing that kept me nervous a few moments longer.

Still not really sure what happened, but my guess is that a lack of water (tank running dry) caused the steam boiler to overheat, shutting it down. Maybe a valve then stuck, so the pump overfilled the boiler as it tried to refill it? Then when the machine cooled, the valve released?

EDIT: After a little more reading this AM, I'm thinking there's a probe in the steam boiler that tells the pump it needs more water. I've been using bottled spring water for the past two weeks, but have just tried a 50/50 of RO and hard tap water. I have reason to believe that perhaps I the mixture was too low in mineral content (e.g. conductivity) for the probe to sense (or the probe is not grounded or working properly) causing the machine to want to call for more water. Might have to check the ground wires the next time I take panels off.
User avatar
Vivaldi Dreamer
Posts: 3045
Joined: Wed Jun 02, 2004 11:52 pm
Location: Central Maryland

Re: Something with the Steam Boiler

Post by chas »

Based on your description of the water you have used, none of the ones you mentioned seems like it would be low enough in mineral content to cause this. It's always possible that you have a flaky sensor or even that you triggered some kind of "corner case" that the new Dream firmware is not handling properly. Keep us posted if it happened again (or if anyone else sees this happen).
LM GS/3 & LaSpaziale Dream v 1.25 (US 120V)
Mazzer Kony E, Customized Rocky
Hottop P/B
Post Reply

Return to “Dream T In Warranty Issues”