Group Temp. Sensor Failure

Did you have an issue or question about operation of your plumbed Dream machine on Day One right out of the box? If so, report it here and also keep us abreast of the resolution.
Post Reply
dbkimmey
Latte
Posts: 14
Joined: Mon Jan 06, 2014 9:56 pm

Group Temp. Sensor Failure

Post by dbkimmey » Mon Jan 06, 2014 11:50 pm

FIrst time poster to the group, thank you all for having me. Just received my Dream T today and am getting the group temp sensor failure message. This locks me out of the program screen. Does anyone know if this is a firmware issue, temp sensor, or a possible way for me to remedy this. I will be contacting CCS in the morning but was so excited to have some fresh espresso in the morning. Thank you for your time and assistance.

goodboyr
God Shot
Posts: 220
Joined: Thu Jan 10, 2013 10:05 pm
Location: Canada

Re: Group Temp. Sensor Failure

Post by goodboyr » Tue Jan 07, 2014 10:07 am

Well.......if you look through the threads you will see my saga on failed group temp sensors. I have been through three replacements on my Dream. According to my retailer, there was a bad batch of temperature sensors that have since been corrected. In any case, its a very easy job to replace the sensor.
As a check yo could remove the cover and check the connection. Its a small black connector. There is a picture in the manual that shows the location of the temp sensor.
Bob
La Spaziale Dream and Baratza Sette 270W

dbkimmey
Latte
Posts: 14
Joined: Mon Jan 06, 2014 9:56 pm

Re: Group Temp. Sensor Failure

Post by dbkimmey » Tue Jan 07, 2014 10:24 am

I did read your saga and it is concerning to me. We are wondering if we should keep the machine. If there are already issues with it it makes me very nervous. Have you had any other issues?

goodboyr
God Shot
Posts: 220
Joined: Thu Jan 10, 2013 10:05 pm
Location: Canada

Re: Group Temp. Sensor Failure

Post by goodboyr » Tue Jan 07, 2014 2:56 pm

I had the first batch, so there were a number of issues that have been corrected. Its a fantastic machine in spite of this and since the fixes has been running nicely. So far so good on the new sensor.
The issues were some leaking tubing (the early batch of machines had some poorly installed tubing) and a failed flow sensor. ) If you have a newer batch machine I doubt these will be problems for you.
Bob
La Spaziale Dream and Baratza Sette 270W

Post Reply

Return to “Dream Day One Issues”